Upgrade to s9y 2.0x

General Q&A.

Upgrade to s9y 2.0x

Postby Havelswan » Mon Aug 03, 2015 10:30 am

Hi Don!
Hi all!

Now version s9y 2.0.2 is out.
Time for the upgrade (from 1.78) of my blog
www.ost-impuls.de

I have Kinetic 1.4

I made the backup of the system files.

Do you know about any issues connected to 2.x?

Best regards

J.
Havelswan
 
Posts: 16
Joined: Thu Sep 02, 2010 1:01 pm
Location: Germany

Re: Upgrade to s9y 2.0x

Postby Don Chambers » Mon Aug 03, 2015 12:09 pm

should be fine, but back everything up first and let me know if there are any problems.
=Don=
User avatar
Don Chambers
Site Admin
 
Posts: 226
Joined: Mon Jan 05, 2009 9:58 am
Location: Chicago, IL, USA

Re: Upgrade to s9y 2.0x

Postby Havelswan » Sat Aug 22, 2015 4:18 am

Hi!

We have problems with the upgrade to version 2.02.

Since for my website I have ssl, it was a longer way in a discussion with developer Timbalu to find out, where the problems come from, thanks to my hoster, who yesterday gave me a strong hint.

Firstly we (Timbalu and I) had the assumption, that the manual upgrade may have been not correctly. So Timbalu recommendet me to repeat the upgrade with the plugin for it (after updating it to current version), which does it automatically.

But later he recommended me to wait with it, because problems may come from not correct settings of the .htaccess-file.

Additonal entries were made here (for my blog) in september last year, when I had moved to a new hoster (dotplex.de) with new server and when my website does not functioned firstly with ssl. So the owner of that hoster wrote something into the htaccess, that forwarding from several urls functioned.

Yesterday my hoster made a test of the php code for the index.php-file,

with ...

"error_reporting(E_ALL);
ini_set('display_errors', 1);",

... because the startpage does not function, while other pages including static pages, dynamic pages, gallery work.

He has got that error:

"Fatal error: Uncaught --> Smarty: Unable to load template file 'content_fullbox.tpl' in '/var/home/schaefer/www/blog/templates/kinetic/index.tpl' <-- thrown in /var/home/schaefer/www/blog/bundled-libs/Smarty/libs/sysplugins/smarty_internal_template.php on line 219"

That file exists and can be read from a php-user, writes my hoster.

The hoster has found these interesting threads describing a probleem:

https://github.com/s9y/Serendipity/issues/331
http://board.s9y.org/viewtopic.php?f=1&t=20408

In the first you have joined the discussion. So it seems to be a problem with Smarty.

You have already told that error and the user pwalter has reported it as well in the s9y-board.

It seems that the problem was not solved yet.

If there is no solution, should I return to 1.78 (if possible) (or now 1.79, cause there was a bug fix)?
That bugfix gave me the motivation to finally upgrade to 2.02.

The ssl may make it more difficult to find out, how the smarty problem can be fixed.

Perhaps I should ask my hoster to switch off for a short time?

When I asked here last time prior to my upgrade try, if you have any concerns according to an upgrade, did you forgot that discussion from 19th march 2015?:

https://github.com/s9y/Serendipity/issues/331

The thread in the s9y-forum about my problems in german is here:

http://board.s9y.org/viewtopic.php?f=10&t=20472

Because of the hint of my hoster I found, that it is time to inform you, Don, especially because of your participation in the Github-discussion and your thread in the forum here:

http://board.s9y.org/viewtopic.php?f=5&t=20321

what may have been the trigger for the discussion.

regards
Havelswan
 
Posts: 16
Joined: Thu Sep 02, 2010 1:01 pm
Location: Germany


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron